Back
Degraded

Rekor search API returning entry missing errors

Started 2 Nov at 08:09pm UTC, resolved 2 Nov at 08:46pm UTC.

Rekor
Resolved

The incident has been resolved. We have increased the memory of the Redis cache.

Posted 2 Nov at 08:46pm UTC.
Created

The search API relies on a Redis cache. Entries are uploaded to the Redis cache in a best effort approach. Redis is out of memory, so entry uploads are failing. When trying to retrieve an entry that was successfully uploaded to Rekor but not to Redis, users are seeing entry missing errors.

This affects rekor.sigstore.dev/api/v1/index/retrieve only.

Posted 2 Nov at 08:09pm UTC.